bundler requires RubyGems version >= 1.3.6

Lors de mes premiers pas dans la réalisation d’application web en Ruby (Ruby on Rails, Rails étant un framework web écrit en Ruby) je me suis retrouvé confronté à l’erreur suivante lors de l’installation d’une application existante : bundler requires RubyGems version >= 1.3.6

Je précise que je développe sous Mac OS X Snow Leopard (10.6.6) et que par conséquent Ruby est déjà installé sur mon système.

Le message est suffisamment explicite  une mise à jour de RubyGems est nécéssaire et ceci se réalise en ligne de commande.

Il faut donc ouvrir une fenêtre de terminal et éxécuter la commande suivante :

[code type= »shell »]<br /><br />sudo gem update –system<br /><br />[/code]

Il est possible de réaliser une mise à jour des package ruby installés en éxécutant la commande :

[code type= »shell »]<br /><br />sudo gem update<br /><br />[/code]